May 14, 2005

Hungarian notation

Hungarian notation seems deprecated.

The Microsoft naming conventions suggest using camel notation (initial lowercase such as someName) for variable names and Pascal notation (initial uppercase such as SomeOtherName) for method names and most other identifiers.

I still prefer hungarian notation for GUI elements like labels, buttons, etc.

What do you prefer ?

Update
More info.

4 comments:

Anonymous said...

I prefer using some_variable for variable names and some_function() for functions or methods.

I don't like that much the Hungarian notation, tho it's not that bad.

Anonymous said...

I prefer using some_variable for variable names and some_function() for functions or methods.

I don't like that much the Hungarian notation, tho it's not that bad.

Luci Sandor said...

Joel Spolsky finds some use for Hungarian-like notations, hence it has an use.

Spoială Cristian said...

:) check my first link